YUM - это утилита управления пакетами из командной строки с открытым исходным кодом для RPM-совместимых операционных систем Linux.
0 ответов

Как вручную обновить Commons.FileUpload в centos7

Я должен обновить установку Commons.FileUpload на сервере m,y из-за проблемы риска, обнаруженной в версии 1.3.2. Я видел, что версия 1.3.3 доступна для скачивания здесь: http://commons.apache.org/proper/commons-fileupload/download_fileupload.cgi Ког…
22 ноя '18 в 12:51
1 ответ

Установите Glibc2, используя Yum

Я пытаюсь установить glibc2 версии 2.11, которая необходима для openoffice 3.4 https://issues.apache.org/ooo/show_bug.cgi?id=119393 но я не могу найти зависимость с ням. У меня уже установлены следующие зависимости. glibc.i686 2.5-49.el5_5.7 install…
09 июн '12 в 02:47
1 ответ

Базовая аутентификация Yum Repo не работает

Итак, у нас есть репозиторий Yum, защищенный с помощью базовой аутентификации. Мое определение yum.repo выглядит так [custom-repo] name=Releases Repository baseurl=http://user:[email protected]:8080/mrepo/nexus-noarch/RPM…
02 июл '14 в 12:51
2 ответа

Как разрешить загрузку пакета только из определенного репозитория с помощью Yum?

Контекст: У нас есть несколько пользовательских репозиториев yum (на CentOS 6), и наши пользователи регулярно устанавливают различное / произвольное программное обеспечение через yum для тестирования. У нас есть пакет, который доступен в нескольких …
15 июн '12 в 15:55
3 ответа

Уведомляется, когда файл, контролируемый puppet, будет изменен yum

Можно ли получить уведомление на консоли, когда пакет, содержащий файл, которым управляет puppet, собирается изменить этот файл? Имеется в виду, что при выполнении обновления yum в yum можно ли добавить пользовательское предупреждение?
15 окт '13 в 16:29
4 ответа

Как мне обновить php на centOS?

У меня установлен php 5.1.6 на сервере centOS, и мне нужен как минимум 5.3.2 (но лучше установить последнюю доступную версию 5.*). Если я бегу yum update php он говорит, что будет обновляться до 5.1.6-34.el5_8 (у меня это 5.1.6-27.el5_5.3)..... како…
16 июн '12 в 12:06
3 ответа

Не могу установить php-mssql в CentOS 5

Когда я пытаюсь бежать ням установить php-mssql Я получаю следующую ошибку --> Processing Conflict: mysql conflicts MySQL --> Processing Conflict: mysql-server conflicts MySQL-server --> Finished Dependency Resolution mysql-5.0.45-7.el5.x86…
21 июн '12 в 12:12
2 ответа

Как я могу перезагрузить ням?

На моем сервере yum использует много системных ресурсов. Мой друг предложил убить его, но я хочу знать, что смогу сначала перезапустить его. Желательно без перезагрузки всего сервера. Тем не менее, я также хотел бы некоторые альтернативы, я бы предп…
25 апр '10 в 03:01
3 ответа

Нужна настройка ням через прокси?

Я пытаюсь заставить мою конфигурацию yum работать снова, но она останавливается на следующем: yum update--verbose Config time:0.091 Yum Version: 3.2.22 Setting up Package Sacks Loading mirror speeds from cached hostfile На последней строке yum прост…
14 авг '13 в 23:29
2 ответа

Ням через http прокси

У меня есть несколько серверов Fedora 13, которые должны подключаться через HTTP-прокси для обновления yum. Весь трафик порта 80 должен быть направлен через этот прокси. Я настроил прокси-сервер в графическом интерфейсе настроек сети. Я могу просмат…
02 июн '10 в 18:58
4 ответа

Мунин на Centos 6 - отсутствует perl MODULE_COMPAT_5.8.8

Я пытаюсь установить Munin на новый VPS через yum install munin но я получаю ошибку об отсутствующем модуле perl: Requires: perl(:MODULE_COMPAT_5.8.8), Это версия Perl, установленная в настоящее время: v5.10.1, Я искал все вокруг и до сих пор не наш…
22 июн '12 в 21:33
3 ответа

Существуют ли CentOS 4 yum хранилища где угодно

Я пытаюсь (несколько отчаянно) преобразовать сервер RHEL 4 без контракта RedHat в CentOS 4, подготовившись к его обновлению до CentOS 5 из-за "шеллшока". Я следую инструкциям, найденным здесь: http://community.spiceworks.com/how_to/show/1496-convert…
28 сен '14 в 20:05
1 ответ

Информация о безопасности пакета репозитория centos yum.. как мне его найти?

Есть ли где-нибудь, где показано, какие обновления безопасности включены в уровни исправлений для версии httpd пакета репозитория centos yum?
21 ноя '13 в 04:53
1 ответ

Конфликты зависимости yum уже установленного пакета

Я хочу установить php 5.6 из репозитория webtatic: yum install php56w php56w-opcache php56w-mysql php56w-mcrypt php56w-pdo php56w-xml Одной из зависимостей является httpd: Installing for dependencies: httpd x86_64 2.2.15-31.el6.centos updates 824 k …
06 ноя '14 в 10:53
1 ответ

Случайно удалил openssl-libs, как мне его переустановить

Я случайно удалил openssl-libs на сервере CentOS 6.4. У меня все еще открыт активный сеанс терминала SSH, но я не могу wget скачать OpenSSL RPM. Yum тоже не сработает, требуется openssl. Есть идеи?
02 дек '13 в 06:00
1 ответ

Каков точный эквивалент создания репозитория yum?

С помощью yum я могу создать репозиторий из папки RPM с createrepo инструмент. Что эквивалентно, чтобы превратить папку файлов.deb в apt хранилище? Речь идет не о зеркалировании репозиториев в восходящем потоке или обслуживании чего-либо в масштабе,…
30 дек '13 в 18:03
1 ответ

Как работает "ням инфо"?

Я хочу знать, как yum info команда работает. я знаю yum info будет отображать информацию об установленном пакете, но я действительно хочу знать, какой файл он читает для этой информации. Будь то чтение файла или чтение из базы данных? Если из файла,…
02 окт '14 в 12:54
1 ответ

yum - найти пакеты с минимальной версией 'x' в конкретном репозитории?

Я настроил несколько репозиториев на моем CentOS 5. Как результат, команда: yum search nagios вывод просто беспорядок - тысячи дублированных пакетов. Чтобы сделать мою жизнь проще, я хотел бы, например, искать пакетные нагио только в определенном ре…
10 июл '12 в 10:01
2 ответа

Я сломал ням - ничего не могу сделать

Я пытался следовать руководству по установке yaffas (zarafa-admin), и я пошел устанавливать пакеты и получил ошибки контрольной суммы для КАЖДОГО зеркала. После примерно 15 зеркал я просто нажимаю CTRL+C, чтобы остановить ням. Now when I run yum any…
22 окт '14 в 03:47
2 ответа

Невозможно загрузить динамическую библиотеку '/usr/lib64/php/modules/ssh2.so'

Когда я пытаюсь запустить любой скрипт php с моим пользователем в оболочке, я получаю следующее предупреждение: PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/ssh2.so' - /usr/lib64/php/modules/ssh2.so: cannot open s…
13 ноя '14 в 16:16