Класс 'Pusher' не найден при установке коэля

Я пытаюсь установить 'koel' на свой VPS (Debian Jessie).
Я следовал этому руководству (а также многим другим руководствам раньше)
http://freedif.org/how-to-install-koel-an-opensource-music-streaming-app/

Была ли установлена ​​npm (возникла проблема несовместимости с fsevent:

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

) и их я пытаюсь сделать композитор установить. Но я продолжаю сталкиваться с этой ошибкой:

> php artisan clear-compiled
PHP Fatal error:  Class 'Pusher' not found in /home/streaming/koel/vendor/laravel/framework/src/Illuminate/Broadcasting/BroadcastManager.php on line 210


  [Symfony\Component\Debug\Exception\FatalErrorException]  
  Class 'Pusher' not found                                 


Script php artisan clear-compiled handling the post-install-cmd event returned with error code 255

Я погуглил, но ничего из предложенного не сработало (при запуске composer require выдает ту же ошибку, поэтому я не могу требовать pusher/pusher-php-server и т. Д.)

на всякий случай вот полный вывод в pastebin: http://pastebin.com/jz22Y74u

2 ответа

Бег composer require pusher/pusher-php-server как предложено @DerfK возвращал то же самое сообщение об ошибке.

Я получил только для правильной установки, запустив либо
composer install или же composer require pusher/pusher-php-server
с --no-scripts флаг.

После того, как он прошел успешно, я смог продолжить использовать композитор в обычном режиме.

Похоже, что файл зависимостей композитора для этого проекта просто "предлагает" установить pusher, но он необходим для того, что вы пытаетесь сделать. Бежать

composer require pusher/pusher-php-server

который должен установить его.

Другие вопросы по тегам